A1019 General Palindromic Number

A1019 General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:
For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2

Sample Output 1:
Yes
1 1 0 1 1

Sample Input 2:
121 5

Sample Output 2:
No
4 4 1

Code:

//进制转换
#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[]) {
int decimal, base1, result1 = 0;//10->base1
scanf("%d %d", &decimal, &base1);
for (int i = decimal, j = 1; i != 0; j = j * 10) {
result1 = result1 + j * (i % base1);
i = i / base1;
}
printf("%d\n", result1);

int reverse, base2, result2 = 0;//base2->10
scanf("%d %d", &reverse, &base2);
for (int i = reverse, j = 1; i != 0; j = j * base2) {
result2 = result2 + j * (i % 10);
i = i / 10;
}
printf("%d", result2);

system("pause");
return 0;
}
//10->base1的进制转换和书上的思路不完全一样,书上的做法我写到题目里了
//以下为本题代码
#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[]) {
int decimal, base, cursor = 0;//10->base
scanf("%d %d", &decimal, &base);
int result[6324];

do {//这样存的数是反的
result[cursor++] = decimal % base;
decimal = decimal / base;
} while (decimal != 0);

//判断回文数,懒得放到一个函数里了
bool flag = true;
for (int i = 0; i < cursor; i++)
if (result[i] != result[cursor - i - 1])
flag = false;
if (flag)
printf("Yes\n");
else
printf("No\n");

//打印
for (int i = cursor - 1; i >= 0; i--) {
printf("%d", result[i]);
if (i != 0)
printf(" ");
}

system("pause");
return 0;
}

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×