A1027 Colors in Mars

A1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:
15 43 71

Sample Output:

123456

Code:

//附两种做法
//这一种写法是书上的写法,简化一下一共十一行
#include <cstdio>
int main(int argc, char *argv[]) {
char base13[15] = "0123456789ABC";
printf("#");
for (int i = 0; i < 3; i++) {//一共就三个数
int decimal;
scanf("%d", &decimal);
printf("%c%c", base13[decimal / 13], base13[decimal % 13]);//因为只是两位数,可以选择不用通用的进制转换代码
}
return 0;
}

//这一种是直接从A1019的进制转换改过来的,几分钟完成
#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[]) {
int decimal, base = 13;//10->base
int result[10];
char base13[3] = { 'A', 'B', 'C' };

printf("#");
for (int i = 0; i < 3; i++) {
int cursor = 0;
scanf("%d", &decimal);
do {
result[cursor++] = decimal % base;
decimal = decimal / base;
} while (decimal != 0);
if (cursor == 2) {
for (int j = cursor - 1; j >= 0; j--) {
if (result[j] < 10)
printf("%d", result[j]);
else
printf("%c", base13[result[j] - 10]);
}
}
else
if (result[0] < 10)
printf("0%d", result[0]);
else
printf("0%c", base13[result[0] - 10]);
}


system("pause");
return 0;
}

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×