A1036 Boys vs Girls

A1036 Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:
Mary EE990830
Joe Math990112
6

Sample Input 2:
1
Jean M AA980920 60

Sample Output 2:
Absent
Jean AA980920
NA

Code:

#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

struct Student {
char name[11];
char gender;
char id[11];
int grade;
};

int main(int argc, char *argv[]) {
int N;
scanf("%d", &N);
Student *students = new Student[N];

int maxno = -1, minno = -1, maxgrade = -100, mingrade = 101;
for (int i = 0; i < N; i++) {
scanf("%s %c %s %d", &students[i].name, &students[i].gender, &students[i].id, &students[i].grade);
if (students[i].gender == 'M') {
if (mingrade > students[i].grade) {
minno = i;
mingrade = students[i].grade;
}
}
else {
if (maxgrade < students[i].grade) {
maxno = i;
maxgrade = students[i].grade;
}
}
}

if (maxno == -1 || minno == -1) {
if (maxno == -1) {
printf("Absent\n");
printf("%s %s\n", students[minno].name, students[minno].id);
printf("NA");
}
else if (minno == -1) {
printf("%s %s\n", students[maxno].name, students[maxno].id);
printf("Absent\n");
printf("NA");
}
else {
printf("Absent\n");
printf("Absent\n");
printf("NA");
}
}
else {
printf("%s %s\n", students[maxno].name, students[maxno].id);
printf("%s %s\n", students[minno].name, students[minno].id);
printf("%d", students[maxno].grade - students[minno].grade);
}

system("pause");
return 0;
}
//过于简单,所以怎么省事怎么写了(指写完一段然后复制粘贴)。

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×