A1006 Sign In and Sign Out

A1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:
SC3021234 CS301133

Code:

#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

struct Record {//不需要char time[8]了,学一下书上直接读hour minute second
char id[15];
int hour, minute, second;
};

int main(int argc, char *argv[]) {//找最早走的和最晚走的
int M;
scanf("%d", &M);
M = M * 2;
Record *records = new Record[M];

Record maxrecord, minrecord;
int maxno = -1, minno = -1;
maxrecord.hour = 0;
maxrecord.minute = 0;
maxrecord.second = 0;
minrecord.hour = 24;
minrecord.minute = 60;
minrecord.second = 60;

for (int i = 0; i < M; i = i + 2) {
scanf("%s %d:%d:%d %d:%d:%d", &records[i].id, &records[i].hour, &records[i].minute, &records[i].second,
&records[i + 1].hour, &records[i + 1].minute, &records[i + 1].second);
}

for (int i = 0; i < M; i++) {
if (maxrecord.hour < records[i].hour) {
maxrecord = records[i];
maxno = i;
}
else if (maxrecord.hour == records[i].hour && maxrecord.minute < records[i].minute) {
maxrecord = records[i];
maxno = i;
}
else if (maxrecord.minute == records[i].minute && maxrecord.second < records[i].second) {
maxrecord = records[i];
maxno = i;
}

if (minrecord.hour > records[i].hour) {
minrecord = records[i];
minno = i;
}
else if (minrecord.hour == records[i].hour && minrecord.minute > records[i].minute) {
minrecord = records[i];
minno = i;
}
else if (minrecord.minute == records[i].minute && minrecord.second > records[i].second) {
minrecord = records[i];
minno = i;
}
}

if (minno % 2 != 0)
minno--;
if (maxno % 2 != 0)
maxno--;
printf("%s %s", records[minno].id, records[maxno].id);

system("pause");
return 0;
}

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×