A1011 World Cup Betting

A1011 World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results — namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.13.02.565%-1)2 = 37.98 yuans (accurate up to 2 decimal places).

Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output:
T T W 37.98

Code:

#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[]) {
double game[3];
double w, t, l;
double profit = 2;
for (int i = 0; i < 3; i++) {
scanf("%lf %lf %lf", &w, &t, &l);
if (w > t)
if (t > l) {
game[i] = w;
printf("W ");
}
else
if (w < l) {
game[i] = l;
printf("L ");
}
else {
game[i] = w;
printf("W ");
}
else//赔率应该不会相等吧
if (t < l) {
game[i] = l;
printf("L ");
}
else {//tie的两种情况都在这里
game[i] = t;
printf("T ");
}
}
profit = profit * (game[0] * game[1] * game[2] * 0.65 - 1);
printf("%.2lf", profit);
system("pause");
return 0;
}
//过于简单了,十分钟写完
//书上的答案思路不太一样

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×