A1009 Product of Polynomials

A1009 Product of Polynomials

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 3 3.6 2 6.0 1 1.6

Code:

#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>

using namespace std;

struct Poly {
int zhishu;
double xishu;
};

int main(int argc, char *argv[]) {
int K1;
scanf("%d", &K1);
Poly *N1 = new Poly[K1];
for (int i = 0; i < K1; i++)
scanf("%d %lf", &N1[i].zhishu, &N1[i].xishu);

int K2;
scanf("%d", &K2);
double *result = new double[2001]();//结果数组,下标为指数,指数最大值为2000,值为系数,带()及调用构造函数初始化为0.0
//memset为什么不行?

int zhishu;
double xishu;
int count = 0;

for (int i = 0; i < K2; i++) {//一边读一边算
scanf("%d %lf", &zhishu, &xishu);
for (int j = 0; j < K1; j++) {
if (fabs(result[zhishu + N1[j].zhishu]) <1e-6)
count++;
result[zhishu + N1[j].zhishu] += xishu * N1[j].xishu;
if (fabs(result[zhishu + N1[j].zhishu]) < 1e-6)
count--;
}
}

if (count != 0) {
printf("%d", count);
for (int i = 2000; i >= 0; i--)
if (fabs(result[i]) > 1e-6)
printf(" %d %.1lf", i, result[i]);
}
else
printf("0");

system("pause");
return 0;
}
//十几分钟完工,何必像A1002一样难为自己呢:/
//有时间记录一下思路

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×