A1065 A+B and C (64bit)

A1065 A+B and C (64bit)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line “Case #X: true” if A+B>C, or “Case #X: false” otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false

Code:

#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[]) {
int T;
scanf("%d", &T);

for (int i = 1; i <= T; i++) {
long long a, b, c;
scanf("%lld %lld %lld", &a, &b, &c);//溢出,两个正数或者两个负数
long long sum = a + b;//注意这里,如果没有sum,直接用a + b的话测试点不通过,奇怪了
if (a > 0 && b > 0 && sum < 0) {
printf("Case #%d: true", i);
}
else if (a < 0 && b < 0 && sum >= 0) {//可能等于,要算一算溢出情况
printf("Case #%d: false", i);
}
else {
if (sum > c)
printf("Case #%d: true", i);
else
printf("Case #%d: false", i);
}
if (i != T)
printf("\n");
}

system("pause");
return 0;
}

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×