A1061 Dating

A1061 Dating

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 — since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week — that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm

Sample Output:
THU 14:04

Code:

#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[]) {
char days[7][5] = { "MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN" };
int day, hour, minute, i = 0;
char str1[61], str2[61], str3[61], str4[61];

scanf("%s", str1);
scanf("%s", str2);
for (; i < 60; i++)
if (str1[i] == str2[i] && str1[i] >= 'A' && str1[i] <= 'G') {//只有7天
day = str1[i] - 'A';
break;
}
for (i++; i < 60; i++)//对,i++不用放在上面,放在这里就行,我跟书上思路基本一样
if (str1[i] == str2[i]) {
if (str1[i] >= '0' && str1[i] <= '9') {
hour = str1[i] - '0';
break;
}
else if (str1[i] >= 'A' && str1[i] <= 'N') {
hour = str1[i] - 'A' + 10;
break;
}
}
scanf("%s", str3);
scanf("%s", str4);
for (i = 0; i < 60; i++)
if (str3[i] >= 'a' && str3[i] <= 'z' || str3[i] >= 'A' && str3[i] <= 'Z') {
if (str3[i] == str4[i]) {
minute = i;
break;
}
}
printf("%s %02d:%02d", days[day], hour, minute);//直接用02格式化就可以控制有无0了

system("pause");
return 0;
}
//读题太重要了,最近这几个题完全就是阅读理解
//写完代码没切换项目,我犯傻了,找了十分钟bug

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×