A1058 A+B in Hogwarts

A1058 A+B in Hogwarts

If you are a fan of Harry Potter, you would know the world of magic has its own currency system — as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27

Sample Output:
14.1.28

Code:

#pragma warning(disable: 4996)
#include <cstdio>
#include <cstdlib>

using namespace std;

int main(int argc, char *argv[]) {//分别是17进制和29进制
int galleon[2], sickle[2], knut[2], gal, sic, knu;
scanf("%d.%d.%d %d.%d.%d", &galleon[0], &sickle[0], &knut[0], &galleon[1], &sickle[1], &knut[1]);

gal = galleon[0] + galleon[1];
sic = sickle[0] + sickle[1];
knu = knut[0] + knut[1];

sic = sic + knu / 29;
knu = knu % 29;
gal = gal + sic / 17;
sic = sic % 17;

printf("%d.%d.%d", gal, sic, knu);

system("pause");
return 0;
}
//不是这也太简单了

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×